P30L registers 8.0 volts and won't reset

Discussion in 'Charge Controllers' started by Zach Webb, Oct 11, 2020.

  1. My charge controller says the battery reads 8.0 volts however when you check the battery with a multimeter it's reading 12.90 also when I turn on my invertor it reads 12.90 I even took my batter and had the charge tested and it tested full. I have tried a soft reset and a hard reset at this point and nothing has changed. I tried to trace the problem back to the pv array and all signs seemed good. The system is a windy nation complete off grid 400 watt solar system.
  2. TomT

    TomT WindyNation Engineer

    It's up to your supplier. But I would say it is bad.
  3. Tuicemen

    Tuicemen Solar Guru

    Loose connections or bad wiring can have an effect. Check all connections for tightness and examine the cables going from charge controler to batteries check with a multi meter at the controler where batteries are connected as well as where panels connect. If everything looks good I'd agrees with Tom. Contact (email) customer support if your still under warranty they most likely will replace it.

Share This Page